Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 15, 2026 - 00:00 EEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 09, 2026 - 10:25 EEST
Scheduled
We would like to inform you about the planned technical works. Wallester is scheduled to conduct network infrastructure maintenance during the designated window:
Components affected: Payment Processing Account Top-Up Wallester Business API Wallester Business Client Portal White-Label API White-Label Back Office Portal
A short service downtime of up to 10 minutes may occur during the maintenance window.
In the event of a detected connectivity failure, prompt measures will be implemented to minimize any resulting impact.
If you need any assistance or have questions, please contact our support team.
Posted Jul 09, 2026 - 09:56 EEST
This scheduled maintenance affected: Payment Processing, Account Top-Up, Wallester Business API, Wallester Business Client Portal, White-Label API, and White-Label Back Office Portal.